win 10+vs2015 caffe 2 安装 build_windows.bat出问题

配置环境:Windows10+vs2015+cuba 9.2+python 2.7.14+cmake3.12 就是按照官网一步一步来的https://caffe2.ai/docs/getting ... mpile
但是在cmd命令行里执行“H:\pytorch\scripts>build_windows.bat”时出现附件中的错误(传不了png格式我给压缩成zip了),cmake我之前没动,不知道怎么调整。显示我要更新pip???缺的文件也不知道在哪,而且no found cmake那是怎么回事……cmaker安装完我并没有动。
错误代码如下:
H:\pytorch\scripts>build_windows.bat
Requirement already satisfied: pyyaml in c:\programdata\anaconda2\lib\site-packages (3.12)
distributed 1.21.8 requires msgpack, which is not installed.
grin 1.2.1 requires argparse>=1.1, which is not installed.
You are using pip version 10.0.1, however version 18.0 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.
CAFFE2_ROOT=H:\pytorch\scripts\..
CMAKE_GENERATOR="Visual Studio 14 2015 Win64"
CMAKE_BUILD_TYPE=Release
-- Selecting Windows SDK version  to target Windows 10.0.16299.
-- The CXX compiler identification is unknown
-- The C compiler identification is unknown
CMake Error at CMakeLists.txt:6 (project):
  No CMAKE_CXX_COMPILER could be found.



CMake Error at CMakeLists.txt:6 (project):
  No CMAKE_C_COMPILER could be found.



-- Configuring incomplete, errors occurred!
See also "H:/pytorch/build/CMakeFiles/CMakeOutput.log".
See also "H:/pytorch/build/CMakeFiles/CMakeError.log".
"Caffe2 building failed"
 
已邀请:

要回复问题请先登录注册